Staying Logged In?

Juls
08-02-2008, 05:51 AM
Scott,
I've noticed that the site keeps unlogging me, and I have to keep logging back in.

This seems to happen like a "time out". For example, if I have another window open and I'm reading another site for a while, when I return to WC I find that it has unlogged me, and I have to sign back in again.

Is there a way to keep ourselves logged in for as long as we want?

I've also noticed that sometimes when I move from one section of the site to another, it will unlog me. I can't say precisely what sections do that, but from now on I will keep track of those issues and write them down.

But, for now, is there something I'm missing with the "time out" issue?

thanks,
Juls

perchjerker
08-02-2008, 03:43 PM
I have not had that happen.

Once I did get logged in after the change, I have not had to login since

maybe something is clearing the cookie you need for the login?

Juls
08-02-2008, 04:09 PM
Well, it used to never knock me off. And, I haven't changed any settings here, so the only other "new" thing is the site.

I just checked my cookie settings, etc. and all is normal there.

I'm confused. :cookoo:

Juls

perchjerker
08-02-2008, 05:29 PM
I dont know either

I have 3 computers and I stay logged in on all of them

Golden
08-03-2008, 08:31 PM
Try dumping your cookies and see if that helps.

I'm like PJ.....it keeps me logged in too so it's a setting on your machine I think.

I'm guessing cookies....check the settings

no1son
08-04-2008, 04:49 AM
This logging out thing is especially bad if one is trying to write a response and gets sidetracked, distracted, or has to look something up.

Sunshine
08-04-2008, 04:59 AM
Hmmmmm....

I'm with Scott and PJ on this one. It has me logged in every time I visit.

Juls
08-04-2008, 02:47 PM
Try dumping your cookies and see if that helps.

I'm like PJ.....it keeps me logged in too so it's a setting on your machine I think.

I'm guessing cookies....check the settings

Ok, It must have been a cookie issue. (I thought I tried that yesterday???)
I am typing this from a new laptop and I closed the browswer and opened it again, and I was still logged in. I am in the process of checking it out on my "old" laptop right now too. I deleted all the cookies and the temp files....be right back...I let you know if it worked....

YES SIR! That was it. It's a cookie issue for anyone else that may be having problems like I had.

Go into the Internet Options and dump the cookies and temperary internet files. Then reopen the browser, relog in....tell it to "remember me", and you should be good to go too.

Thanks Boss Man!

Now, I just have to do it again to the desktop, and all will be well in my world again. lol

Juls

Juls
08-05-2008, 03:49 PM
I thought it was fixed, but it's back to unlogging me again. Hmmmppffff!:boohoo::banghead:

Juls

Golden
08-06-2008, 08:46 PM
Check your ISP, see how often they are clearing cookies.

Something is going on....and I don't think it's my setup because I'm always logged in at home and at work.

If this is a wide spread problem then I need to know.

Otherwise....it's something on your end....but frankly I'm not 100% sure either way since this is a new forum.

no1son
08-09-2008, 11:50 AM
The unlogging seems to be very fast in the "Quick Reply" but far slower if one clicks "Go Advanced". I set my browser to clear all cookies when I close it; so I am never logged in at the beginning of a browsing session to any site. I don't find that to be a problem. The quick termination of the "Quick Reply" is a bit annoying but select "Go Advanced" and there is a work around.

no1son
08-10-2008, 05:35 AM
Is it possible to add an icon for the "advanced" reply to the end of messages like the one for quick reply?

Juls
08-10-2008, 06:32 AM
By clicking the "Post Reply" button on the top or bottom (Left) corner of the page, you get the "advanced" window.

I agree though, that option should be inside the message box with the other options.

As for my getting logged out. There is no pattern...no rhyme or reason.

One minute I'm logged in and the next I'm not.

I can't figure it out.

I don't think It's my ISP, because the old site never logged me out, and other sites still do not log me out, until I physically log myself out, or dump cookies/temp files myself.

Juls

Golden
08-10-2008, 10:24 AM
I'm using the "Quick Reply" and I'm not getting kicked out or logged out.

My computer stays logged in all the time unless I log out and clear cookies.

Check your cookie settings.

If you are using Firefox, click Tools > Options then click the Security tab and set to keep cookies until they expire.

If you are using IE 6.0 (don't have 7.0 because it sucks ;-)
Click Internet Options > Security

I run my browser on "Default" level

Juls
08-10-2008, 12:26 PM
I use MSN for my default browser. I may have found something that may have been the culprit. We'll see....

I'll let you know later...

Juls

Golden
08-10-2008, 05:18 PM
That is part of your problem...MSN is a browser inside of a browser.

Use FireFox...it's the best ;-)

no1son
08-11-2008, 12:59 PM
"If you are using Firefox, click Tools > Options then click the Security tab and set to keep cookies until they expire."

Since I set my Firefox to clear cookies when I close it, the site is more or less working as it is supposed to for me (I suppose). Looks like the differences are in how individual browsers are set up.

Does it also make a difference if walleye central is set as one's home page?

Golden
08-11-2008, 01:15 PM
nolson, you would have to login each time you re-open the browser....which would be correct for the settings you have.

Even if it's your "home page" (highly modified I might assume ;-) you need to login after you close your browser.

I have my cookies set to keep until they expire so when I open WC and I'm already logged in....which works fine for me.

no1son
08-13-2008, 09:54 AM
I keep my "true" home page set to a local html with the links I normally use. I definitely have to log back in every time I open Firefox, which is no big deal, since I also normally log out anyway when I leave a site such as Walleye Central. There is probably a time out after a certain period of no activity that causes some of us to have to log back in from time to time. I deal with that on the mainframe at work all the time; so it really is nothing new to me. Why that doesn't affect all of us I have no idea, unless it has something to do with checking the "Remember Me" box or not. That interval is also probably adjustable somewhere in the configuration of the site, since that is normally a function of the server rather than the client, and I do not get that response from other sites that I log in to; so I think it is probably not in my Firefox configurations. There may be some "wait" period in the site scripts that could be increased. I have to do that for some of the macros I use at work to get around the mainframe normal log off after no activity period. This is not a problem for those that post or reply without logging on, of course.

no1son
08-13-2008, 09:57 AM
If there is a automatic recertification interval in some of our browsers that sends an activity reposnse to keep the login alive and that is longer than your time out, I would like to know about it. To this point I have not found that in Firefox configurations, which is not to say that it is not there.

Golden
08-18-2008, 07:55 PM
I have no idea about "automatic recertification intervals" being an option in the browser settings.

Sometimes a persons ISP will log them out if they appear to be offline for an extended period of time that is preset and different for each ISP.

They make 3rd party software to "ping" your ISP to let them know you are online to fix that problem but I have never used any so I have no idea how they work or which one is a good one.

no1son
08-21-2008, 03:28 PM
What seems odd to me is that some sites do not drop the logon when you browse another window say for a reference or to find a fact, but this one does. That makes me suspect that there are different contact procedures from the various sites to my browser rather than being an issue with the ISP or the particular browser.

I run Firefox at level 2.0.0.16 on WIN98 SE on a Pentium II 350, and have no other problems with this site other than the private message notification I mentioned to you in another post. Were this limited to me I would suspect it to be some lack in my OS or hardware level and I would live with it, but it appears to happen to some with more recent versions of Windows on more modern machines, too.

I would say that in my case the ISP is not responsible; so that sorta leaves one end or the other. I am on DSL anyway; so I am constantly online. The message comes from this site anyway rather than being a network or from my own setup. Walleye Central will log off a user on an open window while maintaining an active web page. The puzzler is that it doesn't do that to everybody, and other sites do not do it to at least some of us who get this response from Walleye Central.

Golden
08-21-2008, 08:09 PM
I'm not sure how big of a problem it is or how to fix it right now.

I have my home machine, my day job machine, my wifes machine, my laptop....and NONE of them get kicked off or has to login unless I logout.

You might check your browser settings and see when you have your cookies set to expire.

Without a cookie, you are logged out because it's the cookie that tells the script who you are and keeps you logged in.

Lose the cookie, lose the login.

If this is a wide spread problem.....I need to know.

If it's my problem.....I can fix it......but I gotta know what it is.

no1son
08-22-2008, 10:35 AM
The way it is, I can live with it. I don't think it is specifically the cookie, either, since the cookie stays live (I think) while my browser is up. This happens to me if I do not act on a live web page at WalleyeCentral for a short bit. Logging back in then allows me to pick up pretty much right where I left off. It is not a fatal problem, more of a petty annoyance if anything.

I expect to have log back in after closing my browser, because I want to clean out cookies from each browsing session then. That is no biggy.

For my own part I don't consider this to be anything like a high priority issue. I have a pretty useable workaround. It is, however, puzzling, since other login websites do not do this with my configuration or through my ISP. It may be a timeout that gets set somehow by making a customized WalleyeCentral homepage. One of these days I will go back to the default and rebuild that to see if that may fix the issue. If that does it, I will report back to you. Until then you need not worry too much about this.

no1son
08-22-2008, 12:12 PM
Hey Golden,

This is a test of a possible fix for logoff interval for inactivity. Passed.

I went to the Customize page and tried to access my profile and preferences, when that failed I then just reset the defaults blindly. I logged off and when I logged back on with the Remember me box checked I rebuilt my customized WalleyeCentral Home Page. Now I do not seem to be getting logged off after any interval of inactivity, not even when closing the browser and reopening it and then logging back in even without re-checking the Remember Me button.

In my case, the problem seems to have been something carried over in the profile, preferences or customized home page from what I had set up for the previous version which I corrected by reinstalling the defaults. I have no idea what was done to the preferences and profile by restoring those defaults, but I seem to have cleared my logoff problem by resetting to default values. Looks like one has to log out and then log back in (probably also a good idea to check the Remember me box, too) for that to work completely. If the problem was in particular types of Customization or Preferences that might explain why some of us had this problem and some didn't.

If that is the case you will have to be careful about restoring backups or you may also restore the faulty settings and recreate the problem for some of us. <grin>

no1son
08-22-2008, 08:05 PM
Follow up:

after about six hours computer shutdown, the logoff problem is still absent. Looks like it has to do with the private settings that some of us brought with us from the previous version. Restoring defaults, logging off and then logging back on to rebuild the private versions seems to clear it, at least it seems to have done so for me.