Home   |  Message Board   |  Information   |  Classifieds   |  Features   |  Video  |  Boat Reviews  |  Boat DIY
Walleye Message Central - Reply to Topic
Walleye Message Central

Go Back   Walleye Message Central > Walleye Message Central > General Discussion > Silverado Trailer Monitor

Thread: Silverado Trailer Monitor Reply to Thread
Your Username: Click here to log in
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-29-2020 09:37 PM
Pokey Fisherman My 2019 dodge has has that but it works off of the trailer brake wire. If I pull my fishing boat with the 4 wire flat connector it does not work but if I hook up to a trailer with electric brakes it works.
05-28-2020 04:30 PM
cliftp
Silverado Trailer Monitor.

The trailer is fixed! Ends up, a ground wire that went to the solenoid for the surge brakes had broken somewhere. It's working fine now. Need to go try for some more bluegill to test it out tomorrow! Thanks for the replies.

Paul C.
05-27-2020 08:07 PM
muskyed Sometimes on new trucks you need to bend the pins slightly where your trailer plug goes in, On my last new boat last year, I also purchased a new truck at the same time. Connection was hit and miss, really sucked trying to back in my garage the first few times, when brakes wouldn't release. Called the boat dealer to say I wanted a new plug harness put on. He said they were seeing it a bit on new trucks, and suggested bending the pins about a 1/16"-1/8" in the outlet on the truck. Plug was loose before I did this, and after slightly bending them, boat plug has went in tight, and never lost connection once.
05-27-2020 01:16 PM
cliftp
Harness

Quote:
Originally Posted by RMBin303 View Post
I would guess that the problem is in the pig tail on the trailer that plugs into the boat. At least that is what I had to replace on mine to keep that from happening on my RAM.
Hi RMBin303, I was thinking that as a possibility but with all the lights working like normal was hoping something the dealer could fix under warranty with the truck. I'll know a little more tomorrow.

Thanks for the reply.

Paul C.
05-27-2020 11:45 AM
RMBin303 I would guess that the problem is in the pig tail on the trailer that plugs into the boat. At least that is what I had to replace on mine to keep that from happening on my RAM.
05-27-2020 09:02 AM
cliftp
Silverado Trailer Monitor

The first time I hooked my boat trailer to my new truck I discovered the trailer monitoring screen. I decided I liked it because it would check the lights for me, kept track of the miles and other items that are probably going to be useful, but I have not figured out yet.

Yesterday, I hooked up the boat to go fishing and all was good. On the way home, it said I no longer had a trailer hooked up. I checked, it was still there!!!! I tried unplugging and plugging back in and it still did not recognize the trailer.

All the lights are still working fine. Any ideas? Trailer or truck? Going in for the first service tomorrow so will ask the dealer but seems strange.

Two man limit of bluegill and crappie by the way.

Thought appreciated.

Paul C.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


All times are GMT -6. The time now is 05:34 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.