Walleye Message Central

Walleye Message Central (https://www.walleyecentral.com/forums/index.php)
-   Electronics (https://www.walleyecentral.com/forums/forumdisplay.php?f=34)
-   -   Let's see your electronics install (https://www.walleyecentral.com/forums/showthread.php?t=436138)

Thalweg 04-17-2020 06:06 PM

John,

Thanks. So far I really like the adjustability and sturdiness of the Blue Water mounts. The cable mounts are just stick on indoor/outdoor zip tie mounts (1 inch squares). I have used them before with good success. Historically I have had to replace them every 3 years or so but it is an easy task.

jbird68 04-23-2020 06:52 AM

[QUOTE=fishsammich;6423258]Here’s my competitor 165CS[/QUOTE]Did you have to run new wires for the power anchor?

Sent from my XT1635-01 using Tapatalk

fishsammich 04-23-2020 06:56 AM

Yes. I ran 8 gauge all the way back to the starting battery. No inline fuse since the anchor had a built in circuit breaker. Tried it yesterday for the first time and it works great! Very happy I put it on. Still have to run the remote dash switch from the unit to the console but I can just use the switch on the back of the unit up front in the mean time.


[QUOTE=jbird68;6428326][QUOTE=fishsammich;6423258]Here’s my competitor 165CS[/QUOTE]Did you have to run new wires for the power anchor?

Sent from my XT1635-01 using Tapatalk[/QUOTE]


All times are GMT -6. The time now is 07:02 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.