Home   |  Message Board   |  Information   |  Classifieds   |  Features   |  Video  |  Boat Reviews  |  Boat DIY
x510 - Walleye Message Central
Walleye Message Central

Go Back   Walleye Message Central > Boats, Motors, Electronics and Trailers > Electronics

Reply
 
Thread Tools Display Modes
  #1  
Old 01-27-2009, 03:41 PM
topstroke/after eyes topstroke/after eyes is offline
Minnow
 
Join Date: Jan 2009
Location: concord
Posts: 8
Default x510

anyone have any info on the lowrance x510c thanx
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-27-2009, 04:48 PM
VaGuy VaGuy is offline
Keeper
 
Join Date: Dec 2008
Posts: 362
Default

I have one, what information were you looking to get?

It's a very nice color fishfinder. If you don't need the gps
there are some good deals out there for this model. I got
mine on the used market for $200. Good as new.
Reply With Quote
  #3  
Old 01-27-2009, 05:56 PM
jim morrison
Guest
 
Posts: n/a
Talking x510c

i bought an x510c last august and mounted next to my 522 and love it. left it set at the factory settings except i use the blue back ground. great unit great price.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 01-28-2009, 07:15 PM
topstroke/after eyes topstroke/after eyes is offline
Minnow
 
Join Date: Jan 2009
Location: concord
Posts: 8
Default

thanx guys i did alot of research on it sounds good just wanted to see if any bad reports will be using it off of geneva and bula on lake erie
Reply With Quote
  #5  
Old 01-28-2009, 08:10 PM
fireboat fireboat is offline
Wallhanger
 
Join Date: May 2008
Location: Omaha, Ne.
Posts: 752
Default

I have a 520c and it keeps locking up and looses the bottom in deep water 50'+. Doesn't matter if I'm moving or sitting still. Worked great all summer, last trip it started acting up. I moved another unit(334c) to the 520's transducer and it worked fine. I down loaded the new software verson and did a reset. There are a lot of posts on WC about the 520c, keep searching, some 520's are having problems. WC is a storehouse of information, great place to learn. Good luck!
Reply With Quote
  #6  
Old 02-01-2009, 04:30 AM
whofan's Avatar
whofan whofan is offline
Wallhanger
 
Join Date: Jun 2006
Location: .
Posts: 1,158
Default

Quote:
Originally Posted by fireboat View Post
I have a 520c and it keeps locking up and looses the bottom in deep water 50'+. Doesn't matter if I'm moving or sitting still. Worked great all summer, last trip it started acting up. I moved another unit(334c) to the 520's transducer and it worked fine. I down loaded the new software verson and did a reset. There are a lot of posts on WC about the 520c, keep searching, some 520's are having problems. WC is a storehouse of information, great place to learn. Good luck!


Me too! My 510c was junk! I tried several software updates and a transducer change out through Lowrances customer service. Never got a lasting fix.
There new graphs don`t work like their old ones do.

My 510 locked up in shallow water when pearch fishing shallow bays

I had a 1998 x75 that gave me 8 years of flawless operation, I foolishly upgraded to the x510c to find out many of Lowrance color models were ridden with bugs.

I`m happy now, I now have this; http://www.vexilar.com/pages/product...ts_lc-507.html

Better than any other graph I have used.

Last edited by whofan; 02-01-2009 at 04:39 AM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 04:52 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.