Home   |  Message Board   |  Information   |  Classifieds   |  Features   |  Video  |  Boat Reviews  |  Boat DIY
Let's see your electronics install - Page 28 - Walleye Message Central
Walleye Message Central

Go Back   Walleye Message Central > Boats, Motors, Electronics and Trailers > Electronics

Reply
 
Thread Tools Display Modes
  #271  
Old 04-17-2020, 05:06 PM
Thalweg Thalweg is offline
Slot Fish
 
Join Date: Sep 2006
Location: Linn County Iowa
Posts: 87
Default

John,

Thanks. So far I really like the adjustability and sturdiness of the Blue Water mounts. The cable mounts are just stick on indoor/outdoor zip tie mounts (1 inch squares). I have used them before with good success. Historically I have had to replace them every 3 years or so but it is an easy task.
Reply With Quote
Sponsored Links
Advertisement
 
  #272  
Old 04-23-2020, 05:52 AM
jbird68's Avatar
jbird68 jbird68 is offline
Keeper
 
Join Date: Mar 2016
Location: Morrison, IL
Posts: 169
Default

Quote:
Originally Posted by fishsammich View Post
Here’s my competitor 165CS
Did you have to run new wires for the power anchor?

Sent from my XT1635-01 using Tapatalk
__________________
Sincerely,

jbird68
Morrison, IL
________________________________________
2006 Alumacraft Navigator 165CS (Crappie Slayer)
2006 Mercury 90HP Optimax
80# Minn-Kota Terrova w/ iPilot
Reply With Quote
  #273  
Old 04-23-2020, 05:56 AM
fishsammich fishsammich is offline
Keeper
 
Join Date: Jul 2016
Location: Down by the river @ SE MN
Posts: 169
Default

Yes. I ran 8 gauge all the way back to the starting battery. No inline fuse since the anchor had a built in circuit breaker. Tried it yesterday for the first time and it works great! Very happy I put it on. Still have to run the remote dash switch from the unit to the console but I can just use the switch on the back of the unit up front in the mean time.


Quote:
Originally Posted by jbird68 View Post
Quote:
Originally Posted by fishsammich View Post
Here’s my competitor 165CS
Did you have to run new wires for the power anchor?

Sent from my XT1635-01 using Tapatalk
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:47 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.