Home   |  Message Board   |  Information   |  Classifieds   |  Features   |  Video  |  Boat Reviews  |  Boat DIY
Bought boat. Needs a prop - Page 4 - Walleye Message Central
Walleye Message Central

Go Back   Walleye Message Central > Boats, Motors, Electronics and Trailers > Motors and Props

Reply
 
Thread Tools Display Modes
  #31  
Old 09-18-2018, 06:45 PM
muskyman73's Avatar
muskyman73 muskyman73 is offline
Keeper
 
Join Date: Jun 2009
Location: Loudon TN
Posts: 309
Default red button

sounds like thats where you attach the kill switch cord that you attach to your life jacket
Reply With Quote
Sponsored Links
Advertisement
 
  #32  
Old 09-18-2018, 07:02 PM
Cobbled Cobbled is offline
Minnow
 
Join Date: Aug 2016
Posts: 58
Default

Button
Attached Thumbnails
Click image for larger version

Name:	20180918_195852_1537318838889.jpg
Views:	27
Size:	351.1 KB
ID:	304522  
Reply With Quote
  #33  
Old 09-18-2018, 07:03 PM
Cobbled Cobbled is offline
Minnow
 
Join Date: Aug 2016
Posts: 58
Default

That's the button I'm talking about. Check thumbnail
Reply With Quote
  #34  
Old 09-18-2018, 07:21 PM
Boondock Boondock is offline
Wallhanger
 
Join Date: Jun 2017
Location: Pueblo west, co
Posts: 687
Default

Quote:
Originally Posted by Cobbled View Post
That's the button I'm talking about. Check thumbnail
Horn? Push it lol
__________________
13 Lund impact 1775
1.7l 115 merc 4 stroke
2 helix si 10's
BT terrova link
Reply With Quote
  #35  
Old 09-19-2018, 03:02 PM
Burr Burr is offline
Charter Member
 
Join Date: Nov 1999
Location: Moorhead, MN, USA.
Posts: 8,475
Default

Here's what the button is for.

https://www.youtube.com/watch?v=NgFhJN4H0T0
Reply With Quote
  #36  
Old 09-21-2018, 09:29 AM
Cobbled Cobbled is offline
Minnow
 
Join Date: Aug 2016
Posts: 58
Default

yes i think that button is the horn

i got the prop yesterday but i found out that i cant use the merc flow torq plasic hub with it. this concerns me because because now i wouldn't have any protection from a rock strike. should i send it back and buy a mercury prop so i can use the plastic hub kit? reason why i didn't buy a merc prop right away is they are so **** expensive.
Reply With Quote
  #37  
Old 09-21-2018, 09:38 AM
Hot Runr Guy Hot Runr Guy is online now
Wallhanger
 
Join Date: Nov 2006
Location: West Chicago, IL, USA.
Posts: 14,310
Default

Quote:
Originally Posted by Cobbled View Post
yes i think that button is the horn

i got the prop yesterday but i found out that i cant use the merc flow torq plasic hub with it. this concerns me because because now i wouldn't have any protection from a rock strike. should i send it back and buy a mercury prop so i can use the plastic hub kit? reason why i didn't buy a merc prop right away is they are so **** expensive.
My guess is that you ordered a Solas Saturn or Titan, which use a pressed-in rubber hub, rather than a Rubex, which uses the hub insert. Send it back and exchange it.

HRG
Attached Thumbnails
Click image for larger version

Name:	Solas Rubex.JPG
Views:	18
Size:	42.1 KB
ID:	304574  
__________________
"I've got a car with a trailer hitch, and a pocket full of money. Do you want to sell that boat today, or not?"
My Mentor, Bill Michalek, circa 1975
Reply With Quote
  #38  
Old 09-22-2018, 10:58 AM
Cobbled Cobbled is offline
Minnow
 
Join Date: Aug 2016
Posts: 58
Default

I'm sending it back Monday. Found a decent prop that uses the merc hub system. Brand is michigan, their prices are decent. Gonna order that one Monday as well.

Had boat out first time yesterday. Not disappointed but not impressed either. The only payload was me (160pounds) my buddy (150) and my dog (60) and it would only do about 37mph With 5100-5200rpm with its current banged up alum prop. With a new SS prop I would hope it would put me at 40mph at least with the same payload. But it seem 19 pitch is max for this rig, was 55 degrees that day. While my top speed was a disappointment the 125 did seem to run well overall, when I got home I did a compression test, 120psi on top 2 cylinders and 125 on bottom 2.

Another gripe other than top speed it that the steering is "clunky". Lots play it seems. I figure if I replace the bolt where the steering cable connects to the motor that will take care of some of the play.
Reply With Quote
  #39  
Old 09-22-2018, 11:06 AM
Cobbled Cobbled is offline
Minnow
 
Join Date: Aug 2016
Posts: 58
Default

Ow and the 2 plus 2 design defiantly seems like not the best idea ever. About get whip lash when the other 2 kick in! And while top speed kinda sucks it got out a the hole very quick, mabey like 50 feet or less
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:42 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.