Home   |  Message Board   |  Information   |  Classifieds   |  Features   |  Video  |  Boat Reviews  |  Boat DIY
Gen 3 Helix Mega Di ? - Walleye Message Central
Walleye Message Central

Go Back   Walleye Message Central > Boats, Motors, Electronics and Trailers > Electronics

Reply
 
Thread Tools Display Modes
  #1  
Old 07-04-2019, 03:43 PM
Mark R Mark R is offline
Wallhanger
 
Join Date: May 2004
Location: Cedar Rapids, Ia, USA.
Posts: 853
Default Gen 3 Helix Mega Di ?

I have a brand new Helix 9 mega di connected to a new Ulterra with built in DI transducer
The GPS & reg sonar work fine but no DI
Anyone have this problem? Suggested solutions?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 07-04-2019, 10:18 PM
rnvinc rnvinc is offline
Keeper
 
Join Date: Feb 2011
Posts: 316
Default

Change the Connected Transducer selection under the Sonar tab to "Built In HW+MDI" ...

Rickie
Reply With Quote
  #3  
Old 07-05-2019, 04:04 AM
Mark R Mark R is offline
Wallhanger
 
Join Date: May 2004
Location: Cedar Rapids, Ia, USA.
Posts: 853
Default

Did that still no joy
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 07-05-2019, 08:10 PM
rnvinc rnvinc is offline
Keeper
 
Join Date: Feb 2011
Posts: 316
Default

Might be time to call HB ...

1-800-633-1468

Rickie
Reply With Quote
  #5  
Old 07-06-2019, 04:44 AM
Hot Runr Guy Hot Runr Guy is offline
Wallhanger
 
Join Date: Nov 2006
Location: West Chicago, IL, USA.
Posts: 14,416
Default

do you have the correct cable?

https://www.technologicalangler.com/...minn-kota-2019

HRG
Attached Thumbnails
Click image for larger version

Name:	MK cable.JPG
Views:	26
Size:	42.8 KB
ID:	311522  
__________________
"I've got a car with a trailer hitch, and a pocket full of money. Do you want to sell that boat today, or not?"
My Mentor, Bill Michalek, circa 1975
Reply With Quote
  #6  
Old 07-06-2019, 07:56 AM
Mark R Mark R is offline
Wallhanger
 
Join Date: May 2004
Location: Cedar Rapids, Ia, USA.
Posts: 853
Default

Thanks. Good suggestion. I was looking at the cables yesterday and saw the one I had said Helix 7 only. Not sure how I missed that on the purchase and install.
Correct cable has been ordered
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 02:52 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.