Home   |  Message Board   |  Information   |  Classifieds   |  Features   |  Video  |  Boat Reviews  |  Boat DIY
Helix 10G2N Settings - Walleye Message Central
Walleye Message Central

Go Back   Walleye Message Central > Boats, Motors, Electronics and Trailers > Electronics

Reply
 
Thread Tools Display Modes
  #1  
Old 09-17-2019, 12:14 PM
eyecatchin123 eyecatchin123 is offline
Minnow
 
Join Date: Jun 2016
Posts: 42
Default Helix 10G2N Settings

Just curious there are a lot of you that seem to have a lot of knowledge with the Humminbird units. I had someone make some changes to mine and now they don't seem to be reading near as well as they were. I restored defaults to get back to the beginning but am wondering if I am setting the wrong transducers for the graphs. My transom graph is on the Mega Imaging transducer and the front through my MinnKota is on the 83/200. When I mark fish they show as a small line instead of a defined arch and I'm guessing its just something in my menu's because I know the fish are bigger fish. Any help with settings appreciated.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-17-2019, 12:44 PM
DW DW is offline
Wallhanger
 
Join Date: Jan 2004
Posts: 1,816
Default

I recently posted my ver 2.0 firmware update experience for my Helix 7. Subsequently I found the sonar sensitivity was weak. I just checked and there is a v2.11 update available describing sensitivity improvements. Check your firmware update status.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:03 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.