Home   |  Message Board   |  Information   |  Classifieds   |  Features   |  Video  |  Boat Reviews  |  Boat DIY
Side Imaging Left side Helix 10 - Walleye Message Central
Walleye Message Central

Go Back   Walleye Message Central > Boats, Motors, Electronics and Trailers > Electronics

Reply
 
Thread Tools Display Modes
  #1  
Old 09-07-2019, 06:37 PM
bbheli bbheli is offline
Slot Fish
 
Join Date: May 2018
Location: Chicago Burbs
Posts: 132
Default Side Imaging Left side Helix 10

I have a Mega G2 and for some reason the left side never seems to show the details the same as the right side which is clear, See image
Attached Thumbnails
Click image for larger version

Name:	Helix.jpg
Views:	120
Size:	339.9 KB
ID:	312770  
__________________
Lund 202 GL Pro V
300 Mercury Pro
15 HP Merc Kicker
15 Talon
Ultera
Humminbird Helix X 2
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-07-2019, 10:29 PM
HodakaD HodakaD is offline
Minnow
 
Join Date: May 2008
Location: .
Posts: 67
Default

Is your transducer on the starboard side of your motor? If so, try trimming the motor up a little. The lower unit may be blocking your transducer signal.
Reply With Quote
  #3  
Old 09-08-2019, 09:52 PM
bbheli bbheli is offline
Slot Fish
 
Join Date: May 2018
Location: Chicago Burbs
Posts: 132
Default

Quote:
Originally Posted by HodakaD View Post
Is your transducer on the starboard side of your motor? If so, try trimming the motor up a little. The lower unit may be blocking your transducer signal.
Yes it is starboard, is there a way to fix that?
__________________
Lund 202 GL Pro V
300 Mercury Pro
15 HP Merc Kicker
15 Talon
Ultera
Humminbird Helix X 2
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 09-09-2019, 07:32 AM
h8go4s h8go4s is offline
Wallhanger
 
Join Date: Apr 2011
Location: Victoria, MN
Posts: 1,310
Default

When the boat is sitting level left to right, is the transducer level left to right?
__________________
Ron.

Read your owner's manual.
Reply With Quote
  #5  
Old 09-09-2019, 07:48 AM
bergsh bergsh is offline
Keeper
 
Join Date: Nov 2011
Location: Chippewa Falls
Posts: 181
Default Splitter and Second Transducer

Most people who run into your issue I know of have solved it with getting the Humminbird splitter for side imaging transducers. Then adding a second transducer to the left side of the motor.

Not cheapest but actually solves the problem.

Shawn
Reply With Quote
  #6  
Old 09-09-2019, 08:06 AM
bbheli bbheli is offline
Slot Fish
 
Join Date: May 2018
Location: Chicago Burbs
Posts: 132
Default

Quote:
Originally Posted by bergsh View Post
Most people who run into your issue I know of have solved it with getting the Humminbird splitter for side imaging transducers. Then adding a second transducer to the left side of the motor.

Not cheapest but actually solves the problem.

Shawn
I already have a splitter for the high speed through hull transducer. Does that matter and do you use the same identical transducer as the main ?
__________________
Lund 202 GL Pro V
300 Mercury Pro
15 HP Merc Kicker
15 Talon
Ultera
Humminbird Helix X 2
Reply With Quote
  #7  
Old 09-09-2019, 08:32 AM
bergsh bergsh is offline
Keeper
 
Join Date: Nov 2011
Location: Chippewa Falls
Posts: 181
Default Splitter

Need identical side imaging transducer.

They make a side imaging to side imaging splitter. Not the high speed dual beam to side imaging if that is the setup you have.

https://humminbird.johnsonoutdoors.c...splitter-cable

Last edited by bergsh; 09-09-2019 at 08:34 AM. Reason: Added Link
Reply With Quote
  #8  
Old 09-09-2019, 12:17 PM
lawson2343 lawson2343 is offline
Keeper
 
Join Date: May 2012
Posts: 408
Default

As HodakaD asked, is your motor or something else blocking the left side? Did you lift the motor?
Or as h8go4s asked, is your transducer level?
You haven't answered those questions.

It might help if you posted two pics, one from the back of the boat showing the position of your transducer and the other from the side of the boat along the transom.
Reply With Quote
  #9  
Old 09-09-2019, 12:55 PM
Ozark Bob Ozark Bob is offline
Wallhanger
 
Join Date: Nov 2007
Location: Lakeview, Arkansas, USA.
Posts: 2,969
Default

Quote:
Originally Posted by bbheli View Post
Yes it is starboard, is there a way to fix that?
Trim your motor up like said before. SI is only good for idle speed. The motor can be trimmed up while doing that. You can buy the proper "Y" cable and a $350 transducer if you need but most don't need to do that. Bob
Reply With Quote
  #10  
Old 09-09-2019, 02:28 PM
bbheli bbheli is offline
Slot Fish
 
Join Date: May 2018
Location: Chicago Burbs
Posts: 132
Default

Quote:
Originally Posted by Ozark Bob View Post
Trim your motor up like said before. SI is only good for idle speed. The motor can be trimmed up while doing that. You can buy the proper "Y" cable and a $350 transducer if you need but most don't need to do that. Bob
Thanks Bob, I will give that a try.
__________________
Lund 202 GL Pro V
300 Mercury Pro
15 HP Merc Kicker
15 Talon
Ultera
Humminbird Helix X 2
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 05:27 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.